RX100で撮り歩くブログ

RX100やRollei B35で写真を撮ったり何やかんやするブログ

postcss-cliをインストールすると Cannot find module postcss とエラーが出てしまう

開発環境を作っていて参考にしたコードなどを見ていると postcss-cli だけインストールしていればPostCSSが動くような書き方をされているが、なぜか自分が試すと Cannot find module postcss とエラーが出てしまってました。

postcssをインストールすれば解決するとは思いましたが、他のコードではpostcss-cliだけで動くのに何でだろうと腑に落ちなくて調べてみると、バージョンによるみたいです。

github.com

postcss-cliのv7系だと不要だけど、v8ではpostcssが必要と書かれ得ています。確かに参考にしていたコードのpostcss-cliはv7でした。おそらく参考にしたブログもそうなんだろうと思います。

ということでおとなしく yarn add postcss --dev をすれば無事動きました。