RX100で撮り歩くブログ

RX100やRollei B35で写真を撮ったり何やかんやするブログ

Netlifyのビルド時にNodeのバージョンでエラーがでる~ The engine "node" is incompatible with this module. Expected version ">=12.13.0". Got "10.24.1"

GatsbyのサイトをアプデしてNetlifyにデプロイしようとするとビルド時に以下のようなエラーがログにでました。

Gatsbyのv3.7.1ではnodeのバージョンを12.13.0以上にしてねってことだと思うんですが、どうやって指定したらいいのかを調べました。

gatsby@3.7.1: The engine "node" is incompatible with this module. Expected version ">=12.13.0". Got "10.24.1"

結論からいうと、プロジェクトルートに .nvmrc というファイルを作り、以下のように記述してデプロイしなおしました。

12.13.0

これで通るはずです。

参考にしたドキュメントとフォーラムはこちら

ドキュメント「Node.js and JavaScript」

docs.netlify.com

フォーラム

answers.netlify.com

管理画面のビルドの設定で環境変数に NODE_VERSION を指定する方法もあるみたいです。もしくは .nvmrc ではなく .node-version を使うか。

どれがいいかは特に比較していないですが、上記のどれかの方法で解決できます。